Как правильно обновить wordpress

Автор:
12 Ноябрь, 2015

Сегодня я расскажу вам как правильно обновить WordPress. Многие, возможно, начнут морщиться, мол чего тут сложного, но поверьте мне на слово, людей, задающих этот вопрос, просто нереально много. Я сам тому пример. При появлении новой версии  WordPress попытался сразу же обновиться, но когда мне не удалось, решил отложить это дело до лучших времен. Лучшие времена настали три дня назад, так как эта напоминалка в админке мне порядком уже надоела.

И я решил быстренько закрыть вопрос. Но не тут-то было. После автоматического обновления, которое, к слову сказать, длится буквально несколько секунд, начал проверять работоспособность сайта и обнаружил проблемы с визуальным редактором. Конкретно, не работала кнопка «Медиафайл» и невозможно было вставить ссылку.

Прошерстил весь интернет, но везде одни и те же стандартные советы: очистить кеш, отключить плагины и после переустановки включать их по одному. Делается это для того, чтобы выявить несовместимость того или иного плагина с новой версией. Все перепробовал по нескольку раз, без толку.

Тогда решил скачать архив и попробовать установить вручную. Кстати разработчики советуют перед этим обязательно сделать бэкап сайта. Нашел описание процедуры, сделал все точно так же, как было предложено, результат- блог не открывается, невозможно даже попасть в админку.

Пришлось делать откат. Если кто не знает, для этого нужно в панели управления своего хостинга выбрать «Резервные копии»

затем выбрать свой домен и доступную дату, т.е. самую ближайшую дату, когда все было нормально и создать заявку на восстановление.

Минут через 5-10 ваш сайт будет в прежнем виде.

Но что делать? Ведь проблема не решена. Стал посещать различные форумы в поисках ответа, зарегистрировался даже на форуме поддержки WordPress, чтобы задать свой вопрос, но нигде толком не могли объяснить, почему некорректно работает именно визуальный редактор. Выдвигались различные версии, были советы сменить движок и даже хостера.

После всех мытарств, на третий день, наконец дошло до меня обратиться в техподдержку своего хостинга. Я пользуюсь вот уже почти 10 месяцев услугами компании Макхост— действительно классный хостинг, убеждаюсь в этом уже который раз.

Через 2 минуты я уже знал что делать. Оказывается сначала нужно выбрать на хостинге самую свежую версию PHP для своего домена, у меня стояла 5.3, довел до 5.5. Для этого нужно в панели управления выбрать «Управление услугами» — «Сайты» и под своим доменом нажать на иконку с надписью «Настройки PHP».

После этого, в подразделе «PHP для домена» выбрать необходимую версию PHP.

Затем, как мне объяснили ребята из техподдержки, раз проблема именно с визуальным редактором, значит нужно обновить плагин «All in One SEO Pack». Можно было, конечно, и самому догадаться, но как известно, все мы сильны задним умом. Мне и в голову не приходило, что нужно обновлять плагины, потому что в консоли постоянно видел надпись — «Ваши плагины не требуют обновления.»

Чтобы обновить «All in One SEO Pack» нужно в админке пройти по пути: «Плагины»- «Добавить новый»- «Популярные». Напротв него будет написано: «Совместим с вашей версией WordPress». Надо сказать, в этой вкладке я насчитал 30 популярных плагинов и если у вас будет подобного рода проблема, обновляйтесь именно оттуда.

Это самая свежая версия, обновлена всего 1 неделю назад. После этого, как по мановению волшебной палочки, редактор заработал как часы. Вывод: всегда выбирайте свежую версию PHP и обновляйте плагины. На этом я закончу свою коротенькую заметку, если она была полезна вам, подписывайтесь на новые статьи блога, а пока я пишу их, почитайте старые из списка чуть ниже. Всего доброго.

Автор статьи — Баяс Батуев

Читайте также:


Комментарии:

Комментарии